плохой импорт http на флаттер для веба

я пытался сделать http-запрос на сервер, но когда я импортирую пакет http, код vs выдает следующую ошибку:

Unable to find modules for some sources, this is usually the result of either a
bad import, a missing dependency in a package (or possibly a dev_dependency
needs to move to a real dependency), or a build failure (if importing a
generated file).

Please check the following imports:

`import 'package:http/http.dart' as http;` from fcfm_pa|lib/src/pages/registro_page.dart at 5:1

кто-то знает, что случилось?

Всего 1 ответ


Вам следует обновить файл pubspec.yaml следующим объявлением библиотеки:

dependencies:
  http: ^0.12.0+4

и затем импортируйте библиотеку. После этого обязательно сделайте через терминал:

flutter pub get

и, возможно, даже flutter clean чтобы убедиться, что у вас все правильно. Сделайте новую сборку, и вы должны быть готовы к работе.


Есть идеи?

10000