Ansible команда всегда показывает предупреждение SETUPTOOLS остановит работу

Команда ansible всегда выводит предупреждение ниже:

/usr/local/lib/python2.7/dist-packages/pkg_resources/py2_warn.py:22: UserWarning: Setuptools will stop working on Python 2
************************************************************
You are running Setuptools on Python 2, which is no longer
supported and
>>> SETUPTOOLS WILL STOP WORKING <<<
in a subsequent release (no sooner than 2020-04-20).
Please ensure you are installing
Setuptools using pip 9.x or later or pin to `setuptools<45`
in your environment.
If you have done those things and are still encountering
this message, please comment in
https://github.com/pypa/setuptools/issues/1458
about the steps that led to this unsupported combination.
************************************************************
  sys.version_info < (3,) and warnings.warn(pre + "*" * 60 + msg + "*" * 60)

информация о системе: Ubuntu 16.04

метод установки: apt-get установить ansible

Как я могу избавиться от этого предупреждения?

СОВЕТЫ: ​​ansible, похоже, использует /usr/bin/python который является python2.7 умолчанию в среде Ubuntu.

Всего 1 ответ


Быстрый и грязный способ:

редактировать /usr/bin/ansible

добавить код:

import warnings
warnings.filterwarnings("ignore")

Но есть ли лучший способ сделать возможным использование среды Python3?

Лучший путь

  1. используйте pyenv или другие инструменты для установки python3

  2. убедитесь, что запускается /usr/bin/env python запускает python3

  3. редактировать /usr/bin/ansible

#!/usr/bin/python -> #!/usr/bin/env python

  1. используйте pip install ansble для установки отсутствующего пакета.

в противном случае ansible module not found .


Есть идеи?

10000