ОШИБКА Отсутствует связывающее приложение / node_modules / node-sass

Когда я использую:

$ пряжи запустить производство

Я получаю эту ошибку (для каждого файла .scss, присутствующего в проекте):

ОШИБКА в ./resources/assets/sass/guest.scss Ошибка сборки модуля: ModuleBuildError: Ошибка сборки модуля: ошибка: отсутствует привязка /app/node_modules/node-sass/vendor/linux-x64-48/binding.node Узел Sass может не найти привязку для вашей текущей среды: Linux 64-bit с Node.js 6.x

Найдены привязки для следующих сред: - Linux 64-bit с Node.js 12.x

Что я пробовал:

$ npm перестроить node-sass

$ npm перестроить node-sass --force

$ rm -rf package-lock.json

$ rm -rf узловые модули

$ npm install

Но я получаю ту же ошибку, у кого-нибудь есть идея? Спасибо !

Всего 1 ответ


Журналы показывают, что ваша версия Node.js 6.x, но Node Sass требует Node.js 8.x.

Вы можете сделать одно из следующих действий:

  1. Обновите версию своего узла до 8.x.
  2. Понизьте свою зависимость Sass до совместимой с Node.js 6.x