Ошибка: сбой связи: Ошибка: не удалось найти предустановленный «модуль: metro-react-native-babel-preset» относительно каталога «C: \ Users \ ...»

Я новый, чтобы реагировать-родной. Я продолжаю получать эту ошибку, когда я запускаю

react-native run-android

Это мой последний пакет package.json, который работал. В последний раз я подталкивал изменения, но теперь он, кажется, сломался.

мой пакет.json

{
  "name": "taxiapp",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "start": "node node_modules/react-native/local-cli/cli.js start",
    "test": "jest"
  },
  "dependencies": {
    "@babel/runtime": "^7.0.0",
    "native-base": "^2.8.0",
    "react": "16.5.0",
    "react-addons-update": "^15.6.2",
    "react-native": "^0.54.1",
    "react-native-maps": "^0.21.0",
    "react-native-router-flux": "^4.0.5",
    "react-redux": "^5.0.7",
    "redux": "^4.0.0",
    "redux-thunk": "^2.3.0"
  },
  "devDependencies": {
    "babel-jest": "23.6.0",
    "jest": "23.6.0",
    "metro-react-native-babel-preset": "^0.48.1",
    "react-test-renderer": "16.5.0",
    "redux-logger": "^3.0.6"
  },
  "jest": {
    "preset": "react-native"
  }
}

Всего 2 ответа


Попробуйте запустить:

del %appdata%Temp eact-* & del %appdata%Tempmetro-* & del %appdata%Temphaste-* & watchman watch-del-all & npm start -- --reset-cache

Если он по-прежнему не работает, вы можете попробовать два решения здесь:

Модифицировать реакцию-родной до 0.57.2

или downgrade babel, из того, что я знаю, RN 0.54 использует babel 6 not 7.

Вот конфигурация, которая работала для меня для RN ​​0.57:

Реагировать на обновление с babel 6 на babel 7


Попробуйте добавить эти правила преобразования в свой пакет package.json:

"jest": {
  "preset": "react-native",
  "transform": {
    "^.+\.js$": "<rootDir>/node_modules/react-native/jest/preprocessor.js"
  },
  "transformIgnorePatterns": [
    "node_modules/(?!(jest-)?react-native)"
  ]
},

Есть идеи?

10000