Предупреждения после обновления до Gradle 5.0

Обновлено до Gradle 5.0, и теперь я получаю такое предупреждение :

'реализация' в 'org.gradle.api.artifacts.dsl.DependencyHandler' не может применяться к '(groovy.lang.GString)'

по крайней мере в трех точках моего build.gradle (ищите // here ):

buildscript {

    ext.kotlin_version = Ƈ.3.10'

    repositories {
        jcenter()
        mavenCentral()
    }
    dependencies {
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // here
        classpath 'com.github.jengelman.gradle.plugins:shadow:2.0.4'
        classpath "org.junit.platform:junit-platform-gradle-plugin:1.2.0"
    }
}

plugins {
    id 'maven'
    id "org.jetbrains.kotlin.jvm" version "1.3.10"
    id "com.github.johnrengelman.shadow" version "2.0.4"
}

ext.moduleName = 'com.github.kotlin_graphics.kotlin_unsigned'

dependencies {

    implementation "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version"  // here

    testImplementation 'io.kotlintest:kotlintest-runner-junit5:3.1.10'
}

repositories {
    mavenCentral()
    maven { url = "https://dl.bintray.com/kotlin/kotlin-eap" }
    maven { url = "https://jitpack.io" }
}

task sourcesJar(type: Jar, dependsOn: classes) {
    classifier = 'sources'
    from sourceSets.main.allSource
}

task javadocJar(type: Jar, dependsOn: javadoc) {
    classifier = 'javadoc'
    from javadoc.destinationDir
}

artifacts {
    archives sourcesJar
    archives javadocJar
}

jar {
    inputs.property("moduleName", moduleName)
    manifest {  // here
        attributes('Automatic-Module-Name': moduleName)
    }
}

test {
    useJUnitPlatform()
}

Зачем? И как я могу решить?

Всего 2 ответа


замените его на implementation "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version".toString()

то не используется GString .


Это невозможно воспроизвести, оно специфично для вашего компьютера и вашей установки вне кода.

Нет проблем с вашим build.gradle как указано выше, и в вашем build.gradle GitHub. У вас есть другие проблемы окружающей среды, влияющие на это. Проверьте переменные среды для вещей, связанных с Gradle или Groovy, также проверьте свой глобальный файл gradle.property в вашем домашнем каталоге. С кодом не возникает проблем.

Тестирование вашего build.gradle в пустом build.gradle :

$ ./gradlew build

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.0/userguide/command_line_interface.html#sec:command_line_warnings

BUILD SUCCESSFUL in 0s
7 actionable tasks: 2 executed, 5 up-to-date

И тестируйте его непосредственно из своего репозитория GitHub: ( обратите внимание: у вас есть некоторые опасные проблемы с классом в предупреждении, которое должно быть разрешено )

$ ./gradlew clean build
w: Runtime JAR files in the classpath should have the same version. These files were found in the classpath:
    /Users/xyz/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-reflect/1.2.50/9fab8887f91c8e17cce1a7522f45dc25976e57b9/kotlin-reflect-1.2.50.jar (version 1.2)
    /Users/xyz/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-jdk7/1.2.31/95d6a67e8787280a82a2059e54e4db7ac6cfe74/kotlin-stdlib-jdk7-1.2.31.jar (version 1.2)
    /Users/xyz/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib/1.3.10/b178c1501609c6e4ee8be635513cb023a466457d/kotlin-stdlib-1.3.10.jar (version 1.3)
    /Users/xyz/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-common/1.3.10/1b19d99229dcedad7caf50534dce38fe82845269/kotlin-stdlib-common-1.3.10.jar (version 1.3)
w: Consider providing an explicit dependency on kotlin-reflect 1.3 to prevent strange errors
w: Some runtime JAR files in the classpath have an incompatible version. Consider removing them from the classpath

> Task :test FAILED

unsigned.Ubyte test > ubyte FAILED
    org.opentest4j.AssertionFailedError at ubyte.kt:35

unsigned.Uint test > uint FAILED
    org.opentest4j.AssertionFailedError at uint.kt:32

unsigned.Ulong test > ulong FAILED
    org.opentest4j.AssertionFailedError at ulong.kt:29

unsigned.Ushort test > ushort FAILED
    org.opentest4j.AssertionFailedError at ushort.kt:30

6 tests completed, 4 failed

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':test'.
> There were failing tests. See the report at: file:///Users/xyz/.../kotlin-unsigned/build/reports/tests/test/index.html

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.0/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 5s
10 actionable tasks: 10 executed

Есть идеи?

10000